Solved

calendar subset writing to file with dex

  • 31 January 2024
  • 2 replies
  • 60 views

Userlevel 1
Badge +4

Hi All,

I’m trying to write a parameter with dex using dex::WriteToFile() procedure. The parameter has an index year that is a subset of the calendar year. (simple calendar with unit year). 

The excel download won’t fill the year column (see screenshot below). I have the latest .dex library 23.1.1.2). 

 

Could anyone explain what went wrong here?

icon

Best answer by Mischa 31 January 2024, 16:03

View original

2 replies

Userlevel 4
Badge +5

This was a regression caused by recent conflicted merges because of the upgrade of our build system for AIMMS 24. It is fixed in DEX 24.0.0.13

Userlevel 3
Badge +6

Hi Marc,

 

Thanks for sharing this observation!

 

I tried out what you describe and I ran into the same problem as you. It does work fine if you use the year calendar directly (as opposed to using the subset of it), I found.

 

I will file a ticket in our internal system to have this investigated.

 

(For those interested, I attached my small example project).

 

Kind regards,

Mischa

Reply


Didn't find what you were looking for? Try searching on our documentation pages:

AIMMS Developer & PRO | AIMMS How-To | AIMMS SC Navigator