Cannot get the same results when using newer version of aimms

  • 14 February 2022
  • 3 replies


Dear all,


Few years ago, I used Aimms to create the file as attached. At that time, CPLEX 12.17.1 package was used to solve the MILP supply chain model. However, when I use newer packages (12.8,12.9,20.1) to run the same file, it gives me very different results. Especially, the “CO2_Capture_Compression_Cost” variable is 0 although it should be 5.6 billion euros as I got. I tried many ways to find why it happens but it doesn’t work. Does anyone can help me in this problem? Thanks a lot for your read and help. 

P/s: please run “ReadCO2sourcedata”, “ReadProductssinkdata”, and “ReadStoragesinkdata” to get initial data from “CO2dat” excel file before running the program. 



3 replies

Userlevel 5
Badge +4

Hi @tuan.huu2007 . If I run your model using AIMMS 4.64 and CPLEX 12.7.1 then I get a solution in which ‘CO2_Capture_Compression_Cost’ equals 0 and the objective value (‘Profits’) equals 1.68e11. I get the same result if I use CPLEX 12.8.

Does the zip file that you attached contain a new or old version of your project?


Hi Marcel Hunting,

I attached the new file that is never opened by new version of Aimms. I worked in this project in 2018-2019. At that time, the version of Aimms should be 4.34 or later (sorry I cannot remember exactly). During my project, I runned Aimms and got results without any problems with ‘CO2_Capture_Compression_Cost’ variable. 

If you run my model with  CPLEX 12.8 or higher, in the first try, you will get 0 for ‘CO2_Capture_Compression_Cost’ variable. But if you continue to run without compiling all, you can get value for this variable but it is not the same what I get few years ago. Do you have any idea why the value is 0 for this variable in the first try?

I continue my project with this model (add new procedure for multi-objective by epsilon method), I always get 0 for ‘CO2_Capture_Compression_Cost’ variable even though I tried many time without compiling all. I just can get the results if changing type of identifier from variable to parameter for ‘CO2_Capture_Compression_Cost’ and other variables which are used to calculate this variable such as ‘MEA_Cost’,’IL_Cost’,...I am not sure why it happens, so could you give me some solutions? Thanks a lot for your help. 



Userlevel 5
Badge +4

Hi @tuan.huu2007 , the definition of the parameters FFR and FUR both contain a variable, namely FR and UtilizationR, respectively. The first time you solve the math program these variables will be equal to 0, and as a result both parameters will be 0.

After solving the math program for the first time, the variables FR and UtilizationR have nonzero values, and as a result the values of the parameters FFR and FUR will change. During the second solve the generated math program will therefore be different.

I do not know why you get a value of 0 for CO2_Capture_Compression_Cost now and not before. I would need the project of the old situation to find out. (The project in your second attachment seems to be the same as the one in your first attachment.) Maybe before you loaded a case which contained solution values for FR and UtilizationR?


Didn't find what you were looking for? Try searching on our documentation pages:

AIMMS Developer & PRO | AIMMS How-To | AIMMS SC Navigator