Solved

Error message: "the scope of index "m" has not been specified"

  • 29 April 2021
  • 2 replies
  • 42 views

Badge

Hello everyone,

I have been using AIMMS for a short time and am still a beginner.

When I encode my objective function, the following error message appears : “the scope of index “m” has not been specified”.

I have tried several ways to solve this problem but none worked.

Has anyone experienced this problem before and can help me? I would be very grateful!

icon

Best answer by mohansx 29 April 2021, 21:00

@Anneco 

 

There seems to parenthesis mismatch in the sum operators in your objective function definition. 

 

sum(i, m, t), (coutdeprod*Qaprod(i,m,t) + sum(i,t), ((coutdesetup*setup(i,t)) + (coutinventaire*Inventaire(i,t)))

 

must be

 

sum[(i, m, t), (coutdeprod*Qaprod(i,m,t)]  +  sum[(i,t), ((coutdesetup*setup(i,t)) + (coutinventaire*Inventaire(i,t)))]

View original

2 replies

Userlevel 5
Badge +2

@Anneco 

 

There seems to parenthesis mismatch in the sum operators in your objective function definition. 

 

sum(i, m, t), (coutdeprod*Qaprod(i,m,t) + sum(i,t), ((coutdesetup*setup(i,t)) + (coutinventaire*Inventaire(i,t)))

 

must be

 

sum[(i, m, t), (coutdeprod*Qaprod(i,m,t)]  +  sum[(i,t), ((coutdesetup*setup(i,t)) + (coutinventaire*Inventaire(i,t)))]

Badge

@mohansx  Thanks a lot !

Reply


Didn't find what you were looking for? Try searching on our documentation pages:

AIMMS Developer & PRO | AIMMS How-To | AIMMS SC Navigator