Error with creating a model on AIMMS Developer

  • 8 November 2020
  • 4 replies

I have created a model on AIMMS for production. There are no errors but still we are not getting any result. I tried multiple modifications, but I am stuck. I am attaching the model for reference. The formulas have not been used anywhere else except for the attached files.


Best answer by gdiepen 9 November 2020, 17:01

View original

4 replies

Userlevel 6
Badge +6

Hi @Aksh 

These screens look fine; can you zip up the project folder and add it? This way we can look at the completeness.

eg , I wonder:

  • did you add data?
  • did you add a Solve statement to MainExecution to run the model 

Most likely you get no errors as your syntax is fine (no compilation issues). Once that is okay, you need to assure your sets and parameters are filled (input data) and your model will solve by adding an execution statement in the procedure you will run to run the model.

In your case: “Solve ObjectiveFunc;” could be added to MainExecution and you can run this procedure F8, or right mouse click action. Hit CTRL-P to open the Progress Window.




Okay I will try working on it with the recommendations provided too. Here, is the zipped project folder for the model.


Thank you!

Userlevel 5
Badge +7



took a quick look at the project. Saw two main problems:

  • You have have not defined an index for the set Product. You put the letter p (which I assume you want to be the index) not in the index attribute, but in the index domain attribute
  • You don’t have a statement anywhere that will initiate the solve. Right now, your project is just a definition of the variables, constraints, parameters, and data and you don’t tell AIMMS that it should solve it. The easiest to do this is to add one line to the procedure MainExecution:
    solve ObjectFunc ; 

After you have added the solve statement to the MainExecution, you can execute it by right-clicking on mainexecution and select run procedure or use the F6 key to run it.

You can also open the AIMMS progress window with CTRL-P to see the output of the solver. After running MainExecution, you should see some information about the mathematical model that was solved.

The model is working now. Thank you guys for all the help!


Didn't find what you were looking for? Try searching on our documentation pages:

AIMMS Developer & PRO | AIMMS How-To | AIMMS SC Navigator