Solved

Excel readin error

  • 19 November 2019
  • 2 replies
  • 128 views

Hi dear community,

 

I tried to follow the tutorial https://how-to.aimms.com/Articles/85/85-using-axll-library.html#importing-data-from-excel-files to read in some data from excel sheet. I’ve installed AIMMSXLLibrary and put the data file directly in the library folder under my project (not sure it is required or not) as shown in the screenshot. Then I created the procedure called “ReadInDataFromExcel” in my project and used the code as shown in screenshot. But when I tried to run the procedure to test whether it can point to the .xlsx file or not, the AIMMS through out this error : The identifier "WorkBookName" has not been declared. I’m not sure what’s going on since I almost copy the code from the website. Could anyone please help?

 

Thanks!

 

icon

Best answer by mohansx 19 November 2019, 20:57

@lin86 

 

WorkBookName is a string parameter in the example which is used as a placeholder for the actual file name. It is optional. 

 

You can directly use your file name in quotations. Something like 

if axll::workbookisopen(“example.xlsx”) then

 

You don’t need to put the excel file in the library folder. Best is to leave it in the root folder of your AIMMS project or inside the data folder. 

View original

This topic has been closed for comments

2 replies

Userlevel 5

@lin86 

 

WorkBookName is a string parameter in the example which is used as a placeholder for the actual file name. It is optional. 

 

You can directly use your file name in quotations. Something like 

if axll::workbookisopen(“example.xlsx”) then

 

You don’t need to put the excel file in the library folder. Best is to leave it in the root folder of your AIMMS project or inside the data folder. 

Thank you @mohansx! It works now! 

Didn't find what you were looking for? Try searching on our documentation pages:

AIMMS Developer & PRO | AIMMS How-To | AIMMS SC Navigator