Model status 13: Error no solution, Solver status 10: Error: Solver failure.

  • 25 December 2020
  • 2 replies

Userlevel 1

While solving a LP, I ran into the following error.  Below some snapshot from the message window. 

 100   9.7583200e+09   9.7583173e+09  3.89e+00  1.71e-01  1.34e-05  2.65e+03
 101   9.7583195e+09   9.7583194e+09  5.20e+00  6.76e-03  6.16e-06  6.06e+04
 102   9.7583195e+09   9.7583195e+09  1.78e+01  1.72e-04  2.39e-06  3.28e+06
Barrier time = 767.38 sec. (945691.46 ticks)
Parallel mode: deterministic, using up to 4 threads for concurrent optimization:
 * Starting dual Simplex on 1 thread...
 * Starting primal Simplex on 1 thread...
Dual simplex solved model.

Compressing row and column files.
Advanced basis not built.
Total crossover time = 300.28 sec. (132581.11 ticks)
Total time on 4 threads = 1136.34 sec. (1101932.44 ticks)
Memory in use by CPLEX 8662892544 bytes.
There is 8.26e+03 Mb in use by CPLEX 12.10.
Warning: Model status 13: Error no solution, Solver status 10: Error: Solver failure.

I am wondering if dual simplex solved the model, why there is error no solution?

Any ideas to troubleshoot this error?

With kind regards and Merry Christmas, 



Best answer by Marcel Hunting 29 December 2020, 15:54

View original

2 replies

Userlevel 5
Badge +4

Hi @bkoirala. Two possible causes are (1) CPLEX ran out of memory or (2) CPLEX faced numerical issues.

The log shows that CPLEX uses 8 Gb of memory but this is the memory in use after the solve. The peak memory in use during the solve could be higher.

More likely CPLEX is running into numerical issues. The final barrier line

102   9.7583195e+09   9.7583195e+09  1.78e+01  1.72e-04  2.39e-06  3.28e+06

shows that the final primal infeasibility is 1.78e+01 which is high. You could try to run the crossover phase using Dual Simplex only, by setting the CPLEX option ‘Barrier crossover algorithm’ to ‘Dual crossover’, to see whether CPLEX prints more information during the crossover phase. You could then also set the CPLEX option ‘Simplex display’ to ‘Every iteration’. It is unclear to me why an “Advanced basis not built” message would result in a solver failure.

If you can share your AIMMS project then I can take a closer look. You can send it to our support by email if your project contains sensitive information. Preferably after adding the entire project folder to a zip file.


Userlevel 4
Badge +6

Hi @bkoirala , Binod,

Hope all is well!

Can you please share if Marcel's answer did solve your issue?



Didn't find what you were looking for? Try searching on our documentation pages:

AIMMS Developer & PRO | AIMMS How-To | AIMMS SC Navigator