solving intermediate non-optimal

  • 20 October 2023
  • 5 replies
  • 130 views

 Hi,

 

Our model exists of 7 optimizations. However, after the 6th optimization it says that it is terminated by the solver, and it ended up in intermediate non-optimal. What does this mean? Did it end up in a local minimum? Or does it mean something else. Can the results be trusted? If not, how can I solve this?

 

Thanks in advance!

 


5 replies

Userlevel 5
Badge +4

Hi @ElineOoms To find out what it means you should enable CPLEX logging by setting the following options:

  • Solvers General option 'Solver listing messages' to 'All'
  • CPLEX option 'Barrier display' to 'Normal' or ‘Diagnostics’

If you then rerun the model, CPLEX will create a status file in the log folder. If you need help with understanding this status file then please copy it here.

Hi @Marcel Hunting,

Thank you for the suggestions. I put the logging on (for a run with other inputs, however this run also ends up in intermediate non-optimal) and this is the file I get. It states:

 

A solution is available, but not proved optimal, due to numeric difficulties during optimization with CPLEX.
A solution is available, but not proved optimal, due to numeric difficulties during the optimization.

 

How can I avoid these numeric difficulties?

 

 

Badge

Hi @ElineOoms

Enabling the AIMMS scaling tool could be a solution to your problem. This tool is designed eliminate numerical instabilities in your mathematical program. 

You can enable this tool by going to: 

Settings > Project options > Solvers general > Scaling > Scale model

There you can also find more information about the scaling tool, by going to 'Help'.  
Additionally, there is a post about the scaling tool on the Community: https://community.aimms.com/what-s-new-at-aimms-26/marcel-hunting-on-the-aimms-scaling-tool-718

Best regards, 

Toine

Badge

Hi @ElineOoms

A quick follow up: Currently, CPLEX Barrier crossover is disabled for your model. You could try enabling crossover: 

Settings > Project options > Specific solvers > CPLEX > General > Solution type = Automatic or Basic

Barrier crossover is disabled if the Solution type is set to Non-basic.

Best regards, 

Toine

Hi @Toine,

 

Thank you very much for your suggestions, we will try this!

 

Kind regards,

Eline

Reply


Didn't find what you were looking for? Try searching on our documentation pages:

AIMMS Developer & PRO | AIMMS How-To | AIMMS SC Navigator