Inf as default values

  • 23 August 2021
  • 5 replies

Userlevel 5
Badge +6

Has anyone solved how WebUI shows default inf values? It is crashing my system over, and over again.


Page Name@contents: Identifier 'Parameter' contains special value 'inf' which is not supported (and displayed as 'Infinity')


Best answer by Edo Nijmeijer 29 October 2021, 15:51

View original

5 replies

Userlevel 1
Badge +4

Dear Gabi, 

Thank you for contacting us! We would like to take a look at your project and analyze the problem. 

Would you be able to drop us an e-mail at sharing your project? We will take the communication from there. 

Thank you in advance, 


Userlevel 5
Badge +6



I already sent my project by e-mail for analysis. Should I send it again?



Userlevel 5
Badge +6



Any updates on this matter? This topic appears as solved, but I am still having trouble with the warnings. 


Best Regards,

Userlevel 3
Badge +5

Hi @gabiservidone

Has your question above been resolved?


As shown below, I could get the default Infinity (∞) value loaded on a WebUI table.

Table with Infinity value


Userlevel 4
Badge +4

Maybe I can add that improvements to handling/showing Infinity were first part of the 4.81.7 release (on September 9th) and were later followed by a fix in 4.82.4 (October 14th) that dealt with the error message that you mentioned.

The error could crash AIMMS when lots of them occurred within short time. We found out when looking at another customer’s issue where it seemed to be related to resizing the columns, but in fact it was the repeated error messages while redrawing the column widths. You may have overlooked it in the release notes for 4.82.4 or, also likely, thought it was not related.

So if this issue is still relevant for you, make sure to check the 4.82.4 hotfix release.


Didn't find what you were looking for? Try searching on our documentation pages:

AIMMS Developer & PRO | AIMMS How-To | AIMMS SC Navigator